News

We have noticed that some users are still using IE9, and as old as IE6. In order to get the full experience, you should use IE10 or later.

This site has been tested using Firefox 37, IE11, Safari 5 and even Opera 12.17 (has minor styling problems but works fine).

We have made some changes to improve the looks for users who have IE8 and IE9.